Need Help w/ PC Issues; Burned SSD, MOBO Won't POST

So, I knew I messed up my PC last night, but I didn't know how badly I messed it up until now. I had my SSD and HDD plugged in, and I (lazily) used the same SATA power connector from my previous PSU with my newly installed PSU. Long story short, it seems that my SSD and HDD are burned out and there's nothing I can do about it. The system started up fine however, and would go to POST since there were no drives/OS it could boot. Now, I'm trying to start it up again to continue troubleshooting and it won't even get that far. I'm using an ASUS Z97-A motherboard, and the CPU_LED is stuck on red. At this point I don't even know what to do. Is there anyway to fix this, or am I going to have to go through the trouble of replacing my entire MOBO and/or CPU?

Thanks for any help you guys can offer me!
2 answers Last reply
More about issues burned ssd mobo post
  1. Its most likely your Mobo and/or hdd/ssd. CPU should be fine. If anyone can confirm.
  2. Bossyfins said:
    Its most likely your Mobo and/or hdd/ssd. CPU should be fine. If anyone can confirm.


    The SSD is definitely fried, I'm unable to currently test the HDD by itself until I fix the MOBO issue I suppose there's no way of finding that out. May I ask, on what do you base your thought that it's the MOBO that's damaged, but the CPU is fine? I'm can't even figure out how the hard drives being fried could injure the motherboard, unless motherboards can be damaged through their SATA connections. Everything else seemed fine yesterday, and today once I tried to turn on my computer it didn't work.

    Thanks for your help!
Ask a new question

Read More

SSD Hard Drives Systems