Solved

How to resolve cyclic redundancy check in external hard disk

I am unable to initialize my new external hard disk drive WD 500GB, each time i get the message DATA ERROR: CYCLIC REDUNDANCY CHECK.....PLEASE HELP ME...THE DISK APPEARS IN DISK MANAGEMENT BUT NOT IN MY COMPUTER...CANNOT ACCESS IT AT ALL PLEASE HELP ME!
14 answers Last reply Best Answer
More about resolve cyclic redundancy check external hard disk
  1. Have you created a partition on the drive and formatted it, or does it not allow you to do so?
  2. It doesn't allow me to do that. I have to initialize it before i can do that. Also this is hardrive connected via hdd enclosure. What can i do? I don't care about the files at all
  3. darkbreeze said:
    Have you created a partition on the drive and formatted it, or does it not allow you to do so?


    It doesn't allow me to do that. I have to initialize it before i can do that. Also this is hardrive connected via hdd enclosure. What can i do? I don't care about the files at all
  4. did you delete all partitions before initalizing? so it was a raw disk?

    crc normally corrupted data cause a hash verify to fail.
    so either the initalization in the external hub is being corrupted or the hdd is doa.
    take the hdd out the enclosure and put it into your pc. in most cases you just unplug it from the adapter and it will slip straight in.
    boot into bios and see if it shows up. quit and make sure it shows on the splash. let windows boot and run the initalize again on the new drive.
    if it works its likey you have a buggy controller board in the external housing. if not then the drive could be dead.

    if all else fails you could try a low level format. but that will depend if theres a tool from the drive manufacturer or 1 for that drive model specifically.
  5. Best answer
    That's exactly what I was going to suggest. While a DOA drive isn't uncommon, it's much MORE common for it to be a problem with the enclosure itself. I also recommend trying to initialize it connected directly to the motherboard.
  6. darkbreeze said:
    That's exactly what I was going to suggest. While a DOA drive isn't uncommon, it's much MORE common for it to be a problem with the enclosure itself. I also recommend trying to initialize it connected directly to the motherboard.


    thanks for your responses gentlemen. I'm just going to take it to my local pc repair shop to see what they can do. Also in the event that i have to get a new external hdd, is there any good budget ones you can recommend?
  7. I have corrected the anomaly of the Best Answer which didn't show up and that was because the poster deleted it after the award had been given. I've picked another but if the OP chooses one he prefers, he can change it, or PM me if he can't.
  8. Thanks. Either way is fine just wondered why nothing was showing up. Hopefully the OP has been able to negotiate a solution.
  9. I have corrected the anomaly of the Best Answer which didn't show up and that was because the poster deleted it after the award had been given. I've picked another but if the OP chooses one he prefers, he can change it, or PM me if he can't.
    it did show up on my account mate. i got the pm saying congrats you solved it.
    now another guy has it...
  10. It's odd because the logs show it was deleted before it was awarded the BA. Time went on and the OP has now decided on another post - sorry you lost out on one but you have a good percentage rate and you're still a bit ahead of Breezy. :D
  11. http://www.imagebam.com/image/a6af50375127283

    mate i aint bothered who got it. it not what i come here for. im just giving a heads up theres errors creeping in all over the place.
    the above is a cap of my pm's to show it was selected successfully. the site as a whole has been flakey again for about 3 weeks.
    i have 1 notification listed permanently but theres nothing in my notification links.
    other errors. i still cant upvote most of the time. it keeps redirecting me to a blank page.
    other times it will put the upvote on while others just refreshes the page without any visible sign i hit the up button.
  12. I agree. Wouldn't bother me at all Saga if you moved the BA to Hexit.

    Also, don't know if you tried this already but if you click on "Mark all as read" beside the notifications it should clear that notification.
  13. Sorry Guys - I'll flag the anomalies up to the Dev team through the permanent staff member who handles these things. Tom's is under some extremely heavy Spam attacks lately and everyone is probably busy trying to block them so some of the flakiness is going unattanded. Hopefully it will soon be business as usual.
  14. No worries, we understand, or at least, most of us do.
Ask a new question

Read More

Western Digital Storage Disk Drive External Hard Drive