New PC build won't post, no display, no beeps. Tried almost everything. What next?

Hi everyone. I just finished building my new PC, but it's having issues. It seems to boot up, but there's no video. The monitor recognizes that a cable is plugged in, but says there's no signal.

You can find my build here, except I've switched the PSU for a EVGA G2 750w, and I'm currently using the onboard graphics (I tested it with my video card and it made no difference).

I've stripped it down so that the only things plugged in/running are my PSU, motherboard, CPU+cooler, RAM, and any case fans/LEDs.

When I plug it in and turn the PSU on, a small green LED turns on on the motherboard indicating it has power. When I press the power button:
8 answers Last reply
More about build post display beeps
  1. Possible cpu compatibility. Is there a way to confirm the bios version your board came with? Support for that CPU was enabled in version 1008.

    See: http://www.asus.com/ca-en/Motherboards/Z97A/HelpDesk_CPU/

    Sucks when that happens
  2. I'm not sure if there is. I can't see anything on the screen, and the motherboard box doesn't display the BIOS version on it or a date.

    I found a few threads mentioning a bios flashing tool that just requires you to put named file on a flashdrive and press a button, but it doesn't look like my motherboard has that button.
  3. I'm sorry I'm not familiar with a "bios flashing tool" so cant really help with that one.

    I would suggest either borrowing a compatible CPU just so you can flash the board, or bring your motherboard to a local shop and have them update it for you. Its unfortunate, I generally prefer the cheapest and easiest option. Try to be 100% sure that this will fix it though, I feel bad that you went out and bought a speaker and diagnostic card, they probably weren't necessary.

    An easy way to confirm is to contact the motherboard manufacturer, give them the info we have and ask them to advise. They can confirm if it will post with that cpu or not.

    **Is there not a tag on the motherboard box, or a sticker on the motherboard itself indicating the version??**
  4. There doesn't seem to be any version number on the box. I will have to check the motherboard itself when I get home later today.
  5. Since I won't be able to check the BIOS version (hopefully it's listed on the board itself) for a few hours.. What would you suggest in the event that the BIOS is fully updated, and that the CPU incompatibility isn't an issue?

    If it's an old version I can just figure out a way to update it, but if it's a current version, should I look into RMAing the motherboard?
  6. If the BIOS thats on it now doesnt support the CPU the only thing you can do is

    Either borrow a CPU it supports then flash it. Or take it to a shop ask them to flash it. Or you'll have to buy a cpu it supports then flash it

    If the mobo supported BIOS flashback you could have updated it with just the PSU
  7. I did some reading and found a few posts saying that you can find the BIOS version in the last 4 digits of the sticker on the motherboard. The last 4 digits on my motherboard are 1205, which seems to match with the BIOS version 1205 as listed on their website.

    Based on that, it looks like CPU incompatibility isn't the issue. I don't think it's a RAM issue since even if I remove all sticks of RAM, the motherboard doesn't beep. I'm going to file an RMA on the motherboard and hope that a new one will fix the issue.
  8. Wanted to come back and update in case some poor soul has the same problem. I RMA'd the motherboard and upgraded to the Z97-Pro since it had the ez BIOS flash button and an onboard error display. I reassembled it outside the case and it still didn't work. It failed to boot with error code 00, which is pretty unhelpful since the manual's description was just "Not used" or something.

    I updated the BIOS thinking it might be another CPU incompatibility issue, but it made no difference.

    I RMA'd the CPU, popped the new one in, and it worked almost perfectly. I still had no display when using DVI (and the motherboard stuck at code 99), but after switching to HDMI it worked perfectly. I popped everything back in the case, inserted my GPUs and moved the monitors over to them, still works great. I'm not sure why it doesn't like the onboard DVI, but since I'm not using the onboard graphics anyway I'm not too concerned.

    I was hesitant to believe it was the CPU, since I'd read "If you think your problem is the CPU, 99% of the time you're going to be wrong". It looks like this was the 1% time.
Ask a new question

Read More

Boot Failure Motherboards Displays