Solved

Random Crashing After Installing New Graphics Card

Recently I've updated my graphics card from a Sapphire ATI Radeon HD 5770 to a Gigabyte R9 290 GV-R929OC-4GD. It loaded up alright but within an hour or three after starting a gaming session the game would freeze and a buzzing sound would come from the speakers. At first I thought it was the card and so i sent it back and got an ASUS R9290-DC2OC-4GD5. Alas, the problem continued. I've so far ran a few benchmarks (prime95, memtest, 3d mark, etc.) with no issue discovered and even used MSI afterburner but unfortunately the problem continued. If I put back my original card it runs fine for long gaming sessions so presently I haven't a clue as to what the issue may be. Any ideas anyone?

My PC's specs are the following:
AMD Phenom II X6 1075T Thuban 3gHz
Gigabyte Motherboard GA-890GPA-UD3H
AZZA PSAZ-850B14 Dynamo 850W Power Supply
Western Digital Caviar Black 2 (x2)
SanDisk Ultra Plus 256GB SSD
32 GB PNY DDR3
6 answers Last reply Best Answer
More about random crashing installing graphics card
  1. Did you uninstall the Gpu drivers before you put the new card in if not that's where your issues come from
  2. I did that and a fresh OS install and the problem still remained.
  3. Azza psu? I would not be surprised if your problem lies with that tbh
  4. Update (11/15/2014): So I acquired a new PSU (a EVGA SuperNOVA 1000G2 1000W ATX12V/EPS12V 80Plus Gold Power Supply 120-G2-1000-XR), installed it and the problem still remains. :-(
  5. Unless you have a sound card the motherboard seems to be the main problem
  6. Best answer
    ok at this point.. I would update ALL drivers.. gpu, motherboard ( and esp audio drivers) and see what that does for you I have had this fix.. after that the only conclusion would be the gpu ( though you really needed a quality psu regardless and evga is quality)
Ask a new question

Read More

Radeon Graphics Cards Sapphire HD ATI