External Hard Drive not recognized by device manager/explorer

Hello, I am having a problem with my Seagate 2TB external hard drive.

The hard drive is not "recognized" by my computer. First, the computer will not get past the desktop's start up screen with it plugged in. I can not access the computer's BIOS because my keyboard will not work on start up with it plugged in. I have tried using different USB 3.0 cords. The hard drive will show up in device manager, but not device management. When I open "Safely Remove Hardware and Eject Media", my hard drive is shown as removable.

The location in the properties of my external hard drive is shown as "Bus Number 0, Target Id 0, LUN 0" instead of "on USB Mass Storage Device" like my other hard drives. Could this be the issue???

I have run DiskPart, but my hard drive is not available. I have run "rescan disks" in device management to no avail. It is recognized on other computers so, I am thinking that it is a problem on my end not the hard drives.

I've googled around for solutions, but none have helped me so far
6 answers Last reply
More about external hard drive recognized device manager explorer
  1. Make sure you have the most current USB drivers installed on your computer.

    Are you able to connect other USB3 devices on that computer? The issue may be with USB3 - it may read USB2 fine....
  2. Unfortunately, I do not own any other USB 3.0 devices to test on. This hard drive worked on my friend's laptop once, and after unplugging it, refuse to work again. My USB drivers were all up to date when I checked under device manager.
  3. It sounds like the Hard Drive controller in the USB is going bad. While it is possible it could be your USB ports, since it worked once in your friend's laptop, but then wouldn't work after that - I would place a bet on a bad drive.
  4. Hi there t0y0hara,

    Most probably the DiskPart did not work because the drive is not detected in the Disk Management. You will get the same results if you try to run testing software I guess.
    After you tried it on another PC and you get the same result, most probably it has a physical issue. The reason may be the enclosure(USB connection lets say). Though, we can not be sure.

    D_Know_WD
  5. Hi All,

    I think the problem may have been with the board that was on my external hard drive. I removed the hard drive from its casing and installed it as an internal hard drive in my desktop and it is back to normal!

    Thank you all for your help :)
  6. Glad you were able to solve the issue.

    Cheers,
    D_Know_WD
Ask a new question

Read More

Device Manager Computers Storage Hard Drives External Hard Drive