Asus sabertooth 990fx r2.0 audio problems (also slight issue with gpu)

----------------------------------------My specs----------------------------------------
mobo: Asus sabertooth 990fx r2.0
gpu: vapor-x r9 280x
cpu: fx8320 (with evo 212 cooler)
ram: 16gb 1600mhz hyper beast
psu: seasonic x850
os: windows 8.1 pro 64bit
ssd: vertex 2 60gb
case: enthoo luxe, standard fans

This is a new build (except for my ssd), fresh windows install, so no conflicts with old drivers.
I didn't get this all together at once, but upgraded piece by piece from an old build. First mobo + ram, followed by cpu, followed by psu + gpu, followed by the case


----------------------------------------Audio problems----------------------------------------
So first problem, as described in title, problems with the audio jacks on my mobo.
The first thing I did was format my ssd, install windows 8.1
download all of the needed drivers for windows 8.1.
Updated the bios to the newest version
Installed graphic driver, audio drivers, nic drivers
Under the asus drivers I couldn't find the newest chipset drivers under windows 8.1, I found them under windows 7, and installed those. (they did list windows 8 as well).
I made sure the onboard audio is on and listed as hd instead of ac97


sometimes I get spammed with audio plugged in / unplugged messages. But even in the sound options to choose a default device, it always said speakers not plugged in,
sound through my graphic card's hdmi port to my receiver works fine, so does my logitech g35 headset.
Optical audio is listed fight (and shown as plugged in, even though it isn't). I only have digital out, yet shows two.

There's a total of 5 amd hdmi audio devices were only one is plugged in (I never had this with my old HD6870 vapor-x)

I don't really care about the audio atm as I run my hdmi to my receiver for movies / music, or use my headset for games. But I do have a normal audio cable running to my receiver which I'd like to use for music once in a while, ...

Reinstalled the drivers to make sure, didn't work either
Removed the device from device manager + uninstalled drivers, rebooted, wanted to see what windows drivers would do, but didn't work either.

----------------------------------------GPU problems----------------------------------------
Tried 14.4 normal, then the 2 new beta drivers
Running a benchmark for over an hour at full specs -> no problem
Played sniper elite 3 completly in one go -> no problems
Played Sacred 3 for 3 days -> no problems
Played the New Transformers game -> problems -> fixed with driver update from normal to beta

Tried to play older games like Assassin's Creed Brotherhood and revelations. Sometimes the display driver crashes and recovers, results in my game hanging.
I need to ctrl+alt+del, start task manager, alt+tab back in to the game, and I can continue playing. Sometimes this happens after a couple of hours. Sometimes after half an hour.


------
I've looked around on google, multiple sites, but couldn't find any solution that helped me out.
13 answers Last reply
More about asus sabertooth 990fx audio problems slight issue gpu
  1. You can't use the onboard hdmi with the gpu hdmi unless you have some kind of dual graphics utility set up depending on support for that and I don't think you can even do it with an AM3+ board as I'm pretty sure you need an APU for this. I might be wrong though, it's possible there's a way to use both the onboard video/audio hdmi and the one on the card but I'm unaware of how or else everybody would do it rather than purchase a second card. I'd set the onboard audio to HD or AC97 and see if that works. HD audio is not the same as HDMI audio. IF using the front jacks make sure you have the correct front panel connected to the board.
  2. Eum, not to be rude, but what does this have to do with my problem? You may have to re-read my post.

    "You can't use the onboard hdmi with the gpu hdmi unless you have some kind of dual graphics utility set up depending on support"
    I am not trying this at all, my motherboard doesn't even have onboard graphics/gpu. The only issue I have with my GPU (r9 280x) is that it runs some games (new games + benchmark tools) really smooth, but the display driver crashes with older games. Other than that I have no issues with it. Except that under the sound properties it lists my card 5 times, 1 being active, 4 being disabled. (http://i59.tinypic.com/nmco5e.png)

    I know HD audio is not the same as HDMI. And it has to be HD for my front jacks header = HD as listed by specs. I can try and put it on AC97 but I highly doubt this will help.

    The wiring is in the right spot, already disconnected the front audio header to make sure it ain't faulty
  3. It has to do with your problem because if you have the onboard audio set to hdmi, you're not going to have any output from the 1/8" jacks.

    You specifically say "I made sure the onboard audio is on and listed as hdmi instead of ac97" which means you've disabled the HD and AC97 output. I'm actually not sure about your statement because I've never personally seen that need to be set for hdmi, generally the hdmi jack is auto sensing and will automatically switch.

    Also, it's HIGHLY likely that Windows 7 drivers may have something to do with your issue. The majority of pre-windows 8.1 drivers are not even within the same driver framework as Windows 8.1 drivers. There are many windows 8.1 drivers that will work on windows 7 machines but few windows 7 drivers that will work without problems on windows 8.1 machines.
  4. And actually, I have that exact board and revision. (You can click my verified cpu-z banner to see for yourself) The windows 7 drivers, while they did work fine when Windows 7 was installed, do not work on this board correctly with Windows 8.1. I know, I just tried it.
  5. darkbreeze, sorry that was at typo, I meant: I made sure the onboard audio is on and listed as hd. Sorry about that, now that's cleared up, ...

    All drivers I use are for 8.1, except for chipset. There aren't any chipset drivers listed under 8.1 OS on the asus support page
    http://www.asus.com/be-nl/Motherboards/SABERTOOTH_990FX_R20/HelpDesk_Download/
    Under win7 however, there are chipset drivers, and they do mention 8 as well in the filename (AMD_Chipset_XPVistaWin7_8_V8973_V901)

    update: fixed typo about that detail in main post, also updated 2nd post as I wrote it when I was tired and realised I said it had to be ac97 but I'll try to put it on ac97. Obviously I meant it was on HD.
    About that. I did try to put it on ac97, with no luck either
  6. Hmm. My board is running under 8.1 with no issues whatsoever in regard to the chipset. Let's see what I can find.
  7. The chipset drivers are ONLY provided through the Catalyst control center now. There used to be ATI chipset drivers and AMD chipset drivers but now the CCC supplies all the needed drivers for the chipset. There are not even chipset drivers listed on the ASUS page for our motherboard. Do you have the Catalyst control center installed? If not you should do so immediately. It will provide the most current up to date drivers for all the board related components such as chipset, integrated video, etc. Make sure to do the full install, except, I would advise you choose the custom install option and uncheck the Gaming Evolved app. It just creates issues. You can download it here:

    http://support.amd.com/en-us/download/desktop?os=Windows%208.1%20-%2064#amd-catalyst-packages
  8. The actual setup for chipset when downloaded from asus (listed under win 7) does indeed include ccc as well. But I had it already installed from when I installed r9 280x driver with custom installer (I never trust defaults, toolbars / malware / spyware and stuff, and turned the api off, as I'm not a developer who needs that api, and the gaming tool)

    Just a rough guess here, but could there be a conflict between r9 200 drivers and our mobo, when it comes to sound.

    At a total loss atm. Tried every suggestion I could find or think off. I think I reinstalled different drivers a dozen of times, even uninstalled the amd audio drivers from r9 280x to see if it would work without that

    Thanks for trying to help me though ^^
  9. I explained what the most likely solution was, if you choose not to try it that's up to you. I understand. However the version of the Catalyst control center included with the Win7 driver package on the ASUS site is likely not the 14.4 version which includes an entirely different set of drivers and utilities specifically created to be compatible with the 8.1 WDK including the new display driver model and mostly all of the Windows driver frameworks.

    Drivers designed for windows 8.1 will often work with an older OS but drivers for the older OS are hit and miss for compatibility with 8.1. Of course, since you said you already tried the 14.4 package my only other suggestion would be that you try to first use the display driver uninstaller followed by the CCC express uninstall to remove all AMD software and drivers, and then reinstall the 14.4 package.

    Sometimes the leftovers from older driver frameworks create issues, as I'm sure you know. I can't understand any other reason for problems with your hardware.

    I guess it's possible you might need to just start from scratch with a clean install and forego ever installing any of the Windows 7 driver packages to start with. Just install all the 990FX drivers from the ASUS site along with the 14.4 and if there is still an issue after that maybe start looking at hardware.
  10. It's not that I don't want to try it, and I did try.

    Just one question: how can any drivers from win7 remain when I did a full format, and wiped my disks before installing windows 8.1?

    You said the drivers are installed with ccc. The chipset drivers I downloaded listed under 7, also mark 8.1 in the filename. When the installer runs, you get the same install options as you get with ccc, because it basicly is a ccc installer.

    I will try to remove all of the drivers again, if it fails, I guess I'll just drop the analog audio and use the optical instead. Doesn't matter for me as all of them run through a receiver anyway.
  11. None. My bad, I missed that you did a clean. I guess I thought you did an upgrade.
  12. Darkbreeze, sorry I didn't reply for a while. I totally forgot about this, and didn't have acces to my pc for a while either. I gave up on those sound plugs as I never really wanted to use it anyway. Got a hdmi cable running to a receiver and a gaming headset. If needed I can always run an optical as well.

    The gpu was a total loss. I ended up returning it, and got a new one. I had to wait nearly 3 months though. After 2 months I gave up. I told them to keep the gpu, to give me my money back, and I ordered an asus r9 290 cuII oc. No issues since. I Been happily gaming for a couple of months. (actually since around february as I got too busy with school after everything returned.

    But thanks for your earlier help mate.
  13. No problem. I also, I think, upgraded since then. I ditched the 280x I had and went with a 290x. I never had any actual verifiable issues with the card, but there were a few weird unexplained glitches that haven't been seen since installing the new card. Glad to hear you got it all sorted out and it's probably a better sound solution anyhow, the way you have it now.
Ask a new question

Read More

Asus Sabertooth Audio Motherboards