Solved

Hyper 212 EVO cooler decent enough for OC-ing an i5 4690K?

Hello, basically the title: I'd like buy a new system with an i5 4690K at it's heart, and would like to know if a Hyper 212 EVO cooler is good enough for this task? If not, can you recommend another cooler that's around the 212's price range?

I haven't been able to find much info about decent coolers for Devil's Canyon architecture.

Also, is the Seasonic S12II-620 Bronze 620W PSU enough for this task?

Thank you!
8 answers Last reply Best Answer
More about hyper 212 evo cooler decent ing 4690k
  1. Yes the Hyper EVO is a great cooler and will OC good.
    There are no CPU Coolers that are better than it and at the same price range.
    You'll kinda hit 4.5-4.6 Easily
  2. Yes its a excellent budget cooler. You can overclock as well, I believe my friend runs his 4670k at 4.4ghz on a 212evo without delidding.
  3. nooo dont do it i bought a coolercrapper for my 4790k with turbo boost at 4.4ghz it was going 95+ i turned turbo boost off and it stays around 75-82 now at stock speed 4.0ghz. i reapplied it twice nothing helped new thermal paste too. i mounted it properly aswell. i think it might just be prime95 though cus alot of haswell users are having trouble with it as well but i would not risk it. the mounting system on the crapper is so bad as well. i broke a sweat just trying to get the thing on the first time. the second time took me 5 mins easy pz but its still really bad.
  4. Its cool. Just buy the Hyper 212 evo
  5. Best answer
    Seasonic S12II-620 Bronze 620W PSU enough for this task? < Not HASWELL compatible.
  6. h100i temps at low 70's now.
  7. I run my 4690k @4.5GHz 24 hours a day 7 days a week with a hyper 212 evo on an Asus z97A mobo, and it has never gotten hot. My idle temps are usually around 26-28c, and after hours of intense gaming it might reach 53-54c.
  8. sanhuy said:
    nooo dont do it i bought a coolercrapper for my 4790k with turbo boost at 4.4ghz it was going 95+ i turned turbo boost off and it stays around 75-82 now at stock speed 4.0ghz. i reapplied it twice nothing helped new thermal paste too. i mounted it properly aswell. i think it might just be prime95 though cus alot of haswell users are having trouble with it as well but i would not risk it. the mounting system on the crapper is so bad as well. i broke a sweat just trying to get the thing on the first time. the second time took me 5 mins easy pz but its still really bad.

    Did you take of the plastic on bottom
Ask a new question

Read More

Power Supplies Cooling CPUs Intel i5 Evo