[Watercooling]Loop won't fill/bleed when pump is on, analysis required!

Hello All,

Long time lurker here,

So I bought the XSPC Raystorm AX360 with D5 Photon res/pump with a Heatkiller 680 waterblock

and this is how i've set this up, i've flushed the radiator extensively but haven't done so for the other blocks....
http://imgur.com/8kZb7mk

My problem is, everytime i try to fill the loop up it doesn't seem to pump the water, plus or minus a couple of large air bubbles, but never significantly reducing/pushing the water into the loop.

Every time i try to fill it, the res topup cap is not on, pump is running, res as high as possible, have tried rocking/shaking from left right front back even turned it upside down and made it lie on its side

The res/pump contains (from the left > right) 1 outlet followed by 2 inlets, i've switched the res/gpu block positions on the res and it seemed to push more water in whilst.

I've tried a lot of things, but every video i watch the pump works wonders and drains the res in a matter of seconds and im wondering if theres major flaws in the design of the loop.

Thanks,

And damn u physics / gravity!
Maiz
1 answer Last reply
More about watercooling loop fill bleed pump analysis required
  1. Welcome to Tom's Hardware Forums!

    Run the pump at a low speed while bleeding. (higher speeds will tend to circulate the liquid along with the bubbles and bleeding will not be very effective).
Ask a new question

Read More

Overclocking