Solved

Please Help Debug BSOD Minidump and Constant crashing.

I keep getting random Blue Screens all day long. I never know what will trigger it. It can be something like copying files from one directory to another, or simply opening a webpage.

The blue screen error says:
DRIVER_IRQL_NOT_LESS_OR_EQUAL (USBXHCI.SYS)


I tried uninstalling the USB3 driver and installing the latest ASRock driver, but it doesn't seem to overwrite it. In the device manager it still shows up as:

Version: 6.2.9200.16656
Date: 6/28/2013
Provider: Microsoft

instead of:

Version: 1.00.0000.0114
Date: 07/03/2012
Provider: Etron


I installed windbg and tried my hand at looking at the minidump information, but it seems a bit over my head. Please let me know if there's any information I need to provide. Thanks for any and all help!

Minidumps:
https://www.dropbox.com/sh/gdoxabkzrli1u66/02X0Q8ZW0l

Sample Dump:
http://pastebin.com/vGFk0K1n

System Specs:
OS = Windows 8 x64 Pro Version 6.2.9200 Build 9200
MB = ASRock Z77 Extreme 9
CPU = Intel Core i7 3770k
GPU = NVIDIA EVGA GeForce GTX 670 FTW
RAM = G.SKILL Sniper 8GB F3-17000CL9D-8GBSR
SSD = Intel 520 240GB
HDD = Seagate Barracuda 1TB ST31000528AS
PSU = Antec EA 650 Green

Peripherals:
USB3 = External HDD
USB3 = Keyboard
USB3 = Mouse
USB3 = Wireless Headset
IEEE 1394a = External HDD
2 answers Last reply Best Answer
More about debug bsod minidump constant crashing
  1. Just an update that I did not have success with trying to uninstall USB3 drivers. I still don't know what's going on and I'm afraid it's not stopping.
  2. Best answer
    notes:
    you might disable the usb 3.0 driver in BIOS or disable the extentions if there are any in BIOS.
    or look for updated to the driver and uninstall the microsoft generic driver and install the custom version you have for your system. The bugcheck you got is in the microsoft generic driver, It looks like you don't have a custom one installed and activated.

    update your BIOS to current version
    http://www.asrock.com/mb/Intel/Z77%20Extreme9/?cat=Download&os=BIOS
    your current version has provides a hardware database to windows with clearly incorrect values in it.
    You need to update the BIOS or reset the BIOS to the defaults and reconfiure it to get the database that the BIOS makes to rebuild.

    -after you update the BIOS you might want to take a look at the BIOS settings for your USB chip, Maybe disable any extensions to the chip settings to get it to work correctly.

    - as to the windows install, you have issues there, you are running some very old drivers that are just going to cause you some pain.
    drivers from 2008 are just bad news. you might want to remove some of you optional software. Ramdisk, asrock software, virtual cd software,...
    but it is up to you. They are not a direct cause of any problem with your usb controller. That will be the BIOS and BIOS setting for the contoller.

    also, the debugger was unable to confirm that all of your windows files were not corrupted. You might want to check directly with
    the system file checker

    run cmd.exe as a admin
    then run
    sfc.exe /scannow (this will try to check the files and repair them)

    if that finds a corrupt file but can not fix it then run
    dism.exe /online /check-image /restorehealth (this will get a trusted image from a trusted online source to do the repair)


    BIOS Release Date 11/28/2012
    BIOS Version P1.80

    Manufacturer ASRock
    Product Z77 Extreme9
    Processor Version Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
    update to 1.90 version
    http://www.asrock.com/mb/Intel/Z77%20Extreme9/?cat=Download&os=BIOS
Ask a new question

Read More

Blue Screen Windows 8 Debugger