Solved

Mobo won't post. Tried everything

Hey guys. Recently I bought a Z87-G45 from MSI and an Intel i5 4670 haswell. I'm having trouble getting the thing to post. I stripped it down to its bare components, jumped the PSU, tried clearing the CMOS, everything. I narrowed it down to my mobo, CPU, and 2X4gb of Corsair Vengeance. My last power supply caught on fire due to me being careless and plugging the PSU molex wire into my older mobo system fan. :pfff: The only part that i'm still trying to use from that old build is the ram. Could that be the problem? And if it is how do I go about solving this?
2 answers Last reply Best Answer
More about mobo post
  1. you need to go to Corsair's website and use their RAM configurator program/app, just tell it your mobo info and it will list all the compatible memory they make for it. See if your existing memory is shown. If not, you will probably have to buy new memory.
  2. Best answer
    Take both sticks of RAM out and see if you get any beeps from the system. Then try each stick of RAM by itself. This checklist will give you some more troubleshooting ideas.
    "No POST", "system won't boot", and "no video output" troubleshooting checklist
    "No POST", "system won't boot", and "no video output" troubleshooting checklistThis checklist is a compilation of troubleshooting ideas from many forum members. It's very important to actually perform every step in the checklist if you want to effectively... Read More
Ask a new question

Read More

RAM Power Supplies Motherboards Systems