Solved Closed

ASRock Z87 Extreme9/ac Motherboard memory issues

Hi All,

Am having a problem with a new PC build. Components all put together and am testing everything and it appears as though there is an issue with the DIMM slots.

I'm running an ASRock Z87 Extreme9/ac with Intel i7-4770K and 16GB G.Skill RAM (F3-2400C10Q-16GTX).

At boot it halts at the memory check and states an error in either channel A or channel B of the DIMM banks. The RAM I am using is straight off the ASRock approved memory support list, therefore compatibility should not be an issue.

I've tried configuring the BIOS to see if it was something there causing the issue, but no matter what I do in the BIOS it continues to fail at the memory check.

When all four DIMM slots are full the boot halts at the memory check. When I take out two memory sticks the boot is fine and will go straight into Windows.

I've tried clearing the BIOS and loading default values, I've tried removing the CPU and inspecting the pins etc, I've tried putting in the custom values into the DRAM profile as per the G.Skill RAM timings, I've ran memory checks all to no avail.

As part of the motherboard UEFI BIOS it offers a feature of checking on the hardware in your system. When I go into this area it displays a diagram of the motherboard and all of the relevant slots that are populated with cards and memory etc. This diagram shows that all four DIMM slots are occupied, but on the front page of the BIOS it is only picking up two DIMM slots???

So far ASRock have been pretty average in their tech support. They haven't suggested anything that I haven't already tried. In fact I don't even reckon that they read my initial tech support request, for I mentioned in there that I had already carried out certain tests but they suggested that I carry out the same tests.

Anyway, I was wondering if anyone else has this motherboard and has had this problem. If so, did you manage to fix the problem and how did you do it?

I look forward to any assistance that you can provide.
22 answers Last reply Best Answer
More about asrock z87 extreme9 motherboard memory issues
  1. Make sure you have the latest BIOS and mobo drivers, then try setting XMP and see if that stabilizes things, if no joy there, may have to raise the System Agent Voltage Offset a bit about + 0.10
  2. Tradesman1 said:
    Make sure you have the latest BIOS and mobo drivers, then try setting XMP and see if that stabilizes things, if no joy there, may have to raise the System Agent Voltage Offset a bit about + 0.10


    Thanks Tradesman. I'll give it a try. I'm pretty confident the BIOS is the latest (v2.10 from memory) but I double check and try the other suggestions.
  3. Keep me updated
  4. Tradesman1 said:
    Keep me updated


    Ok, so I've still been unable to resolve the issue at this stage. Here is the error at BIOS memory test stage;


    Here is a image of my UEFI BIOS main page. You will see that it only recognises two sticks of memory and not the full four sticks;


    This pic is of the System Browser, a feature where it shows you what is plugged into what slot, such as RAM, Video Cards, Sound Cards etc;


    This is the OC Tweaking area in order to do some configuration on the RAM settings. It doesn't matter what settings I change in this area it makes no difference;



    They say pictures speak a thousand words, therefore hopefully these pics help.
  5. Ok, so I'm back in town and still trying to tackle this persistent memory problem.

    Since getting back I've tried to isolate the issue and thus far the RAM looks good. All sticks work well individually and have all passed a memtest.

    I've pulled the CPU out and had a look at that. I'm a little confused here as people keep saying check the pins to ensure that there are not any bent ones, but what I have noticed with Haswell chips is that there are no "pins". Where the pins use to be are copper/gold plated contacts, so the whole "... check that there are not any bent pins" suggested by some people is confusing me a little.

    On the memory side. I've test the memory in the following configurations with the results of such as follows;

    1 x 4GB Stick in slot A1 = fine
    1 x 4GB Stick in slot A2 = fine
    2 x 4GB Sticks in slots A1 & A2 = fail
    1 x 4GB Stick in slot B1 = fine
    1 x 4GB Stick in slot B2 = fine
    2 x 4GB Sticks in slots B1 & B2 = fail
    2 x 4GB Sticks in slots A1 & B1 = only recognises B1
    2 x 4GB Sticks in slots A2 & B2 = only recognises B2
    4 x 4GB Sticks in Slots A1, A2, B1 & B2 = only recognises B1 & B2

    I've tried increasing the System Agent Offset Voltage by an extra 0.10v to a total of 0.40v but that hasn't made any difference either unfortunately.

    I was kind of hoping to avoid having to RMA the board as that will require a total disassembly of the rig to get the board out (draining water loop, removing rads and fans to get board out).

    Hopefully someone might have an answer as to the cause of the problem. I am not 100% that it is just the board, as the CPU could be at fault, but how exactly can I isolate it to the CPU? As I said above, some people said that there may be a bent pin(s) but on these news chips there are no pins so I'm not sure what else I can check with the CPU.
  6. With the sticks working individually fine, and in individual slots fine, sounds like the MC in the CPU, it could possibly be the mobo, but think I'd bet on the CPU (MC)
  7. So I finally got a hold of a friend of mine who also has an Z87 mobo (also ASRock) with DDR3 RAM. I was able to drive to his place today and took my rig with me. We did some chopping and changing and were able to discover the following information;

    In my rig, with my CPU, my mobo and his RAM the PC booted in all tested configurations (he only has 2 x 4GB sticks, so we could only test two slots at a time). No BIOS or memory test failures.

    In his rig, with his CPU, his mobo but my RAM the PC failed at all the same points that I mentioned in my earlier post.

    Just to be sure we then swapped out CPU's and I put my CPU in his mobo and vice versa.

    My rig was now running his CPU, my mobo and his RAM. All booted fine with no issues. I then put my RAM back in and got the same problems again.

    In his rig was my CPU, his mobo and my RAM. Boot problems were as previously experienced. I then put his RAM back in and the PC booted normally.

    Therefore, this is pretty clear cut a memory issue yeah? The funny thing is that all RAM sticks passed memtest etc, but when you put all four sticks together or even in parallel (ie A1 & B1 or A2 & B2) they cause boot issues.

    I'm now pretty sure it is the RAM, but just wanted to see what other people thought before I rush out and RMA them.

    Thanks for your assistance thus far Tradesman.
  8. Best answer
    Yep, sounds like it's the sticks, and time for RMA/exchange
  9. Sounded that way when everything started pointing directly at the RAM. Thanks for your help Tradesman.
  10. No worries, let us know how it goes
  11. I'm curious of the outcome. I have run into a similar issue. Unfortunately, i do not have another system to test against.
  12. thatiguy said:
    I'm curious of the outcome. I have run into a similar issue. Unfortunately, i do not have another system to test against.


    Hey, it appears I forgot to update this thread. thatiguy my issue ended up being the RAM. I RMA'd it, got a new kit, put it in and off it went with no further issues.

    I just can't believe the tech support from ASRock weren't more interested in getting to the bottom of it, considering the first sign of issues their suggestion was to RMA the motherboard. GSkill on the other hand wanted to help isolate the issue and test the RAM a bit more and it was GSkill that believed it was the RAM and to RMA it.

    So in the end once the RAM was replaced with a new kit of the exact same specifications all was well. Hope this helps.
  13. GSkill is very good about working to resolve problems
  14. Tradesman1 said:
    GSkill is very good about working to resolve problems

    I have similar issue with my Asrock mobo and Corsair memory what kind memory had your friend ?
    or you ended up with same RAM model, just exchanged?
  15. What Rock mobo and what model of DRAM along with what CPU?
  16. Asrock Fatali1ty Z87, with i7 4770k and Corsair Vengeance pro 2400 ( CMY 16GX3M2A2400C11R ). RAM is not on the ASrock list so I hope changing to approved will fix issue, i have opposite, my A channels work but B don't.
  17. Let's check a few things first, do you have the latest BIOS, will want that...also any OC on the CPU, depending on your 4770K may need a slight OC to run dual w/ 2400 sticks, so if no OC might try 4.0 or 4.1, then enable XMP and select profile 1 in the BIOS and try....If you don't want to OC the CPU, might try manually setting the sticks to 1866, 9-10-9-28, 1.6
  18. I had no OC done, XMP was active. Tried manual setting you posted and issue persisted.
  19. No joy at 1866? did you try both in slots 1-3 or 2-4 from CPU? If so, might try in 1-2 or 3-4 (see if it may be a channel issue)
  20. 1-2 and 3-4 in pairs don't boot at all ( its not listed as possible setup in mobo instruction also ). 1 or 2 work by them self, 3 or 4 don,t work. Mobo sees RAM in its utility ( like case before mine ) but CPU doesn't recognize B ( 3,4).
  21. Sounds like the mobo or memory controller (MC)...might try loosening the CPU cooler then snug it back down and try (if a corner or side is too tight can unbalance the CPU so it doesn't have full pin contact), if no joy might pull CPU and look for dust/debris in socket and check for bent/broken pins
  22. Ok guys got my mobo changed and all is working 100%. SO it was mobo after all. Thanks for your help.
Ask a new question

Read More

G.SKILL Memory ASrock Motherboards extreme9/ac