Can't remove the write-protection on usb flash driver

I have a 16GB usb flash driver which somehow decided to turn on the write-protection and now I can't even format the usb flash driver.

I have already tried theses solutions:

using disk part and the attritubutes disk clear readonly command which didn't do anything

I tried the HKEY_LOCAL_MACHINE/SYSTEM/Control/StorageDevicePolicies
which I had to create and then created a WriteProtect type REG_DWORD
and it also didn't work

Then I tried the Safe Mode Command Prompt but I receive the same messTage :
The disk is write protected

There is no special switch on the usb that allow to turn on/off the write protected thing.

At this point I'm even wondering if there is a solution at all.
Any help would be very helpful
3 answers Last reply
More about remove write protection usb flash driver
  1. time for a new disk.
  2. (Never mind that previeou answer) New post: Easeus Partition Manager? You may be able to format through that.
  3. I just tried the EaseUS Partition Master and it didn't work neither thx though
Ask a new question

Read More

Format Storage Command Prompt Write Protection USB Flash