New build won't boot, no POST, mobo doesn't have integrated graphics. I need some help here.

Ok, so I'm a pretty experienced PC builder (having about 5 solid builds under my belt), but I'm stumped here and need help. I initially put the PC together and got nothing. So I took a step back and made sure everything was correctly connected and everything was all good. Tried again- nothing. No POST, monitor gets nothing. The PC is turning on, there's no cycle on and off stuff going on, but it won't DO anything after powering up! This Mobo doesn't have integrated graphics so I figured it might be a problem with that. I took the card out of my reliable PC and stuck it in. Same result. (actually I missed a step of what I did: After the initial no-boot, I troubleshooted it down to believe it was the mobo. I had removed all extras and replaced the PSU with another with the same result. I sent in the mobo as quickly as possible and got my new one back with the same result. THEN I tried changing out the cards). So where I'm at now: I've re-seated everything multiple times and checked all connections (testing with a properly working PSU). I KNOW for a fact it can't be the mobo this time around because I took all RAM sticks out and I got the expected 3 beeps. Here's the build specs:
mobo: MSI 970A-G46
RAM: Gskill ripjaws 2 sticks 8GB total
HDD: 1TB WD 7200 RPM
PSU: rosewill RD600
CPU: Phenom II quad core 3.4 GHZ
Graphics: -Originally bought card: Radeon HD5450
-taken out of my PC for testing: Elitegroup GT520

I have been completely stumped and would really like to try and have this finished by the end of the weekend. Thank you for any replies ahead of time!
6 answers Last reply Best Answer
More about build boot post mobo integrated graphics
  1. Best answer
    First you should try isolating the malfunctioning part. I see you have already tried swapping out the PSU and the motherboard. Try swapping out the ram and if that doesn't work try verifying the processor works in another motherboard.

    Your ram is on your motherboard's support list so it will work so long as it isn't doa.
  2. try bread boarding with minimal equiped (one ram, proc, gpu, psu), if it still fail it could be the proc...
  3. My first next step would be to isolate the ram, using 1 single dimm and 1 stick (typically A1 dimm).

    I have had this issue, where i ran each stick or ram in 1 dimm slot and then hit memok on my asus board. it worked, and i was able to install 6 dimms and its been posting and running smooth ever since.
  4. Ok well I've been working on the problem for a while now today and the PC is already bread-boarded right now with only essentials installed. I will try pulling out a stick of RAM from my trusted PC and see what that does. But if that doesn't work I would have to agree, I think it could be the CPU. I didn't think CPU's are ever really DOA though are they? Or at least not commonly.
  5. I snatched a RAM stick out of my personal computer to try really quick and BOOM instantly booted up. It was the RAM sticks. Thank you so much for all your help!
  6. Zombiecide said:
    I snatched a RAM stick out of my personal computer to try really quick and BOOM instantly booted up. It was the RAM sticks. Thank you so much for all your help!

    Great to see that you had a spare stick around, it becomes so much harder to isolate issues without reliable parts around. You are right about processor, I've never received a DOA one but that doesn't mean it won't happen once in awhile.
Ask a new question

Read More

Graphics Boot Motherboards New Build