Sign in with
Sign up | Sign in
Your question
Solved

Chrome not working after Windows 7 updates

Last response: in Applications
Share
15 March 2013 20:14:47

Okay, I am about to lose it, literally, because I cannot resolve this issue, and this is the ‘only’ place I know of where I can get some sound advice.

I had recently wiped my hard drive clean, to do a fresh install of Windows 7. My registry was becoming a little cluttered, and after about a year and a half of installing, updating, and upgrading software, I felt as though my system needed a fresh start. I am a software and web developer, and I like to keep my system minimal, however, I do rely on many different software packages and services to develop (i.e.: Java JDK, Apache, PHP, MySQL, UDK, Maya, Adobe, the .NET framework, and every major web-browser currently available), and it is crucial that everything works in harmony. Now, I have not even begun to install anything (other than Windows 7), and I am already experiencing the same issue repeatedly. Here is what I am experiencing.

When I install Windows 7, I ‘disable’ Windows from performing their ‘automatic updates’. In the past, have had too many experiences where one of Microsoft’s updates renders something within my system as un-functional, and I am almost 100% positive that this is occurring again, however, I cannot pin point which update is doing this, nor exactly what is causing this issues. What is happening is I cannot get Chrome to access the internet, at all. It runs, however, it will not access the internet. It is crucial for me to have this service, since this is my #1 choice for internet browsers, and (since I develop web-sites) I require it to work out cross-compatibility issues. I cannot work without this, so please, I do not need Firefox, Opera, IE, etc… fan boys suggesting that I simply switch browsers. I require as many popular browsers as possible, so that I may perform my ‘job’ as best as I can, and in all honesty, I find that chrome suites my profession better than other browsers.

Now, with that out of the way, every browser that I have installed (IE, Opera, Firefox, Safari) all work fine, except for Chrome, and I only experience this problem after I update Windows 7. I have installed Windows 7 eight times already, and each time I try something new, and I still cannot get Chrome to function. Each time I install Windows, I have been going through the same routine (after noticing this problem). I first), Install Windows, second), install motherboard drivers, third), install LAN drivers, and fourth), install Chrome. At this point, Chrome works fine, and everything is sunshine and flowers. Then, I go on to install my Video drivers (ASUS Nvidia GeForce 660 DirectCUII), USB drivers, and other peripheral drivers. Still, at this point everything works fine. Then, before I install Kasperksy Antivirus (to rule out the possibility of a conflict) I begin updating Windows 7. Now, after the first set of updates, which is something like 102 critical updates, and after I restart my computer, Chrome does not work anymore. I have tried installing chrome ‘after’ Windows 7 completes all of its updates as well, with the same result. In addition, I have also tried:

1. Running CHKDSK /R & CHKDSK /F twice in administrator mode; no errors or bad sectors found.
2. Running a DEEP antivirus/malware scan on ‘all’ of my drives, twice, and nothing was found.
3. Running Chrome with the ‘-no-sandbox’ attribute, with no effect.
4. ‘Use automatic configuration script’, and ‘Use a proxy server’ within my internet options are ‘not checked’.
5. Running Chrome in ‘incognito’ mode, with no effect.
6. I have tried repairing Window 7 three times, with no effect.
7. Clearing out my memory, 4 times, with no effect.
8. Running CCleaner to clear out my registry, with no effect.
9. Updating my BIOS, with no effect.
10. Insuring that all of my drivers are up-to-date, with no effect.
11. Using an IP address to resolve a connection, with no effect.
12. And I have restarted my machine about a thousand times, with no effect.

I understand that this is a lot, and I would honestly be in debt to whoever could assist me with this matter. Currently, I have lost 4 days of both work and school because of this problem, and I am pulling my hair out attempting to figure this issue out. Apparently there are, and have been similar cases like mine (on the internet), however, none of the suggestions that I have found have worked in my case. I thank everyone who is able to lend their assistance towards this matter in advance, and I deeply appreciate any advice or knowledge which could assist me within this matter. Thank you for your time.
a b $ Windows 7
15 March 2013 20:44:44

Well, I'll throw out a few things that come to mind

I assume you're only installing the pre-selected updates and no optional updates, such as for a device driver? Have you tried running Chrome as administrator? Does it work if you uninstall or disable (or never install) Kaspersky AV?
m
0
l
a b $ Windows 7
15 March 2013 20:54:18

I will throw a couple of ideas:
1) Is it possible that windows firewall or other firewall/anti-virus/anti-malware/etc program is blocking the connection for Chrome?
2) Do you have any plugins to Chrome that could be causing the issue (also - plugins may be blocked by #1)?
3) Do you sign in for Chrome to synchronize previous installations?
4) Did you restore the folders from backup for Chrome? (I have had corrupted saved data from Chrome that created this issue - to solve, you may have to rename the folder C:\Users\<username>\AppData\Local\Chromium\User Data\Default to "Default-SAV").
m
0
l
Related resources
15 March 2013 22:14:24

@SchizTech & @ronintexas

Many thanks for replying so soon, I sincerely appreciate it.

@SchizTech:

To answer your first question, yes. I am only installing ‘some’ of the ‘pre-selected’ updates. There are a few that were ‘pre-selected’ that I ‘un-selected’, either because I believed that it could potentially cause a problem with Chrome, another process or service within my system, or simply because I did not need it, and the update was not critical. In addition, because I installed almost all of my hardware/peripheral driver’s pre-windows update, Windows update never had these drivers on its update list. I checked this thoroughly, to insure that none of my drivers (which I insured where up-to-date) where going to be over-written via a generic Windows based driver.

To answer your second question, yes. I have attempted to run Chrome as administrator, and I still receive the same effect; the program begins, I can access settings, however, I cannot access an url, even when I use an IP address. I cannot even loop back to myself, or, go to my router through Chrome, although I can through every other browser on my computer.

To answer your third question: yes and no. Chrome works if I install Windows 7, and install Kaspersky, however, it does not work after I update Windows 7. When I noticed this I began attempting to simply install Windows 7, then install chrome (without Kaspersky), and although Chrome worked pre-update, it did not function post-winblows update. Therefore, after I have installed Windows 7, then Chrome, Chrome works. After Windows update, it does not work. Kaspersky is not even involved, even though I have it on here now, up-to-date, and whether it is currently enabled, or disable, it does not make a difference… Chrome still will not resolve an URL or IP address.

@ronintexas:

1) No, I have disabled everything, including Windows firewall, and Chrome will not work. The last 5 times that I have installed Windows 7, I would not even install Kaspersky, my one and only antivirus/malware security suite, therefore, it was not even present to cause a conflict on a fresh install.

2) I thought of this too. In addition, I know that my plugins are backed up by Google, therefore, I even went as far as to create a ‘new’ Google account (fresh), with no plugins, and I still receive the same effect, post-windows update.

3) Yes, I have tried this, and all of my bookmarks, extensions, and history is sync’d. Again, this will all work on a ‘fresh’ install of Windows 7, and the only time that Chrome will discontinue connecting to the internet is when I run Windows update.

4) Yes, I have tried this as well, with no effect. After I go to ‘\Users\<username>\AppData\Local\Chromium\User Data\Default’, and rename the Default folder as "Default-Backup”, and sign back into Chrome, Chrome creates a new ‘Default’ folder under “C:\Users\...\User Data\”, and I still get the same effect.

In addition, I am installing the ‘newest’ version of Chrome, and I am using Windows 7 x64. Moreover, after I install all of my Windows updates, they are not listed (for whatever reason) under CCleaner or Programs & Features (or Add & Remove Programs). I know that they were before I did this fresh install, however, now nothing is listed, not even the .NET framework packages which were listed before I wiped my drive clean.

Thanks again, in advance for any help, and/or assistance.
m
0
l
a b $ Windows 7
15 March 2013 23:16:05

more brainstorming:

Does the issue persist if you perform a system restore? Is Internet Explorer 10 included in the updates you've installed? It's unlikely there's a compatibility problem between them but we're down to crazy answers at this point.

Can you clarify what isn't present in the program list after the updates? I'd suggest trying to un-install and re-install Chrome or do a repair if the installer presents that option but if Chrome is among the programs that disappear you're stuck.

Does Chrome install any Windows services, that you can re-start in the Services control panel (services.msc)? Does everything look right under the properties of the Chrome executable? Does the compatibility troubleshooter come up with anything?
m
0
l
16 March 2013 00:43:08

@SchizTech:

To answer your first question, yes. I have done a system restore three times already, and after each time, the same issue persists.

To answer your second question, no. I have not installed IE10. In-fact, I did not even install IE10 on my system before I wiped my drive, simply because it is so new, and you never know what sort of reaction people may have. I generally wait awhile before I update to any new ‘major’ version of IE, due to past problems and experiences.

To answer your third question, I cannot really explain what is not within the program list, because prior to me wiping my drive I recall at least 30 some odd programs that I had downloaded through Microsoft’s Windows update service, like .NET framework packages, Hot fixes, and even some updates. Currently, there is ‘nothing’ from Microsoft in there, which seems strange, because I know that I just updated my system with over 200 different updates.

To remark on your suggestion regarding re-installing Chrome, I have done this so many times and in so many different variations that I do not know what else I can do. In addition, it would be ‘really’ nice if I would receive some sort of error or something, however, I cannot find any sort of debug.log, or error.log anywhere; therefore, I have no clue as to what is stopping Chrome from accessing the internet.

To answer your fourth question, there are not any services which linger after Chrome is shut down. Personally, this is odd, because before I wiped my drive, Chrome would have one or two services running in the background of Windows at all times, and if you wanted to shut it down, you had to go into task manager, and then ‘end task’, however, with this ‘fresh’ install, either Windows 7, or a Windows 7 update is not allowing this to enable somehow, which could be preventing Chrome from running. Then again, I have attempted to install Chrome after all of my Windows 7 updates have been installed, and I still receive the same reaction, Chrome doesn’t resolve an URL or IP address, and there are ‘no’ chrome services running in the background.

To answer your fifth question, everything looks fine to me when it comes to the properties of the Chrome executable, however, I do remember that prior to this new Windows install, Chrome installed under “C:\Users\...”, and now it is installing under “C:\program files (x86)\” for whatever reason. I do not see how this could potentially make a difference, and discontinue my service, seeing as though most every other web-browser is installed under this directory.

To answer your sixth question, no, Windows compatibility troubleshooter is of no use. It does not find and/or resolve any issues. In-fact, this is one of the very first functions that I attempted to perform to fix this issue, and I have tried it several times since, including with this current installation. Everything seems peachy, with my system, and Chrome prior to Windows update. The only problem that I am getting is after I update Windows, with something like 102 updates, Chrome is no longer functional, and if I install Chrome after all of Windows updates have installed, the same issue occurs. This is both frustrating, and mind boggling. I frankly have no idea how to fix this, and I seriously need some sort of event viewer or error.log of some sort, to attempt to see what is happening.

Thanks again for your suggestions.
m
0
l
16 March 2013 19:07:11

Okay, this problem still persists, and I have not yet been able to find a solution anywhere. In a desperate attempt to find a solution, I have ran the following program to attempt to resolve this issue:

- Kaspersky Pure 2.0 (Deep scan)
- - No Virus's, Mal-ware, or threats found
- - - This is the 3rd time that I have performed this

- AVG Internet Security 2013 (rootkit scan, whole computer scan)
- - No Virus's, Mal-ware, or threats found

- Malwarebytes (Flash Scan, Quick Scan, Full Scan) = No Virus's, Mal-ware, or threats found
- - No Virus's, Mal-ware, or threats found

- Spybot - Search & Destroy (System Scan)
- - No Virus's, Mal-ware, or threats found

- ComboFix - (System Scan)
- - No Virus's, Mal-ware, or threats found

Seeing as though none of these programs have been able to find a single threat on my machine, I absolutely have no idea what is causing this issue. In addition, it is still bugging me that Chrome is not installed under "C:\Users\...", because it was before, and worked just fine. As of now (and every other time that I have recently installed it) is has been installing under "C:\Program Files (x86)\...", which I see no problem with, however, I cannot help but wonder if this is how Chrome is supposed to install.

If anybody out there is able to lend their assistance, that would be great. In all honestly, I would like to see if there is anything 'technical' that I can do, to view the actual Chrome events which are taking place, to identify what is happening. All I get is a white screen in Chrome, and the loading icon within the tab simply continues to role. It will never error out, it will simply continue to attempt to resolve whichever URL or IP address that I have placed in there. Again, this is the only browser that I am having problems with, and I am a web-developer, and really need this browser for 'cross-compatibility', and for a whole list of other reason (i.e.: extensions, history, unique functions, etc...).

Thanks in advance toward anybody who can help.
m
0
l
a b $ Windows 7
16 March 2013 20:43:08

I believe "Program Files" is where the newest version of Chrome is meant to be installed; I do recall reading that Google changed the default install location in one of the previous releases. As far as I know there's no way change the installation location since the Chrome installer doesn't offer that option.

What installation source are you using? Do you have any way to verify the integrity of the Windows install disk? Official copies of Windows 7 SP1 can still be downloaded from the following link, which you can activate with your key.

http://www.mydigitallife.info/official-windows-7-sp1-is...

m
0
l
a b $ Windows 7
16 March 2013 20:48:14

You've checked the properties of the chrome executable, but what about the whole Chrome folder? The one difference I could envision there being between an install to the Users directory and the "Program Files" is the ownership. What happens if you open properties on the folder as admin and take ownership of it (check the box to do this recursively for all files and subfolders)?

Another idea just occurred to me: go to the Users item in the Control panel. First check that no extra accounts have been created by some piece of software in the update process (some programs install their own system accounts). But then try to create a new user profile and run Chrome from that new user (with ownership set back to System). This will ensure there isn't an error in your user profile causing trouble.
m
0
l
17 March 2013 19:50:40

@SchizTech:

In reply to your first post, yes, I too just figured this out, that Google is now having Chrome install under "Program Files", instead of under "Users". I think this was in response to a myriad of users complaints in regards to how Chrome was installing under “Users”, instead of “Program Files”. Personally, I do not care, as long as the program works. In addition, from what I gather there is ‘supposed’ to be a way that you can install Chrome under “Users”, by using Google Chrome’s ‘Alternate installer for one user account’, which I used, and it did not work either. This stand-alone installer still installed Google under ‘Program Files (x86)’, and I am still unable to use it.

Moreover, I too pondered whether my version of Windows 7 had something to do with it. I get Windows 7 Ultimate x64 through my college, for free. Therefore, just to be on the safe side, after I checked my entire system with all of the above mentioned antivirus & mal-ware programs I downloaded a new .img, burned it, and installed it. After the installation, I created a restore point, prior to downloading any updates for Windows 7. Once my backup was complete, I installed Chrome, and it did not work!? I still experienced the same problems, I can log-in to my account, which downloads all of my bookmarks, and extensions, so it ‘has’ to be interfacing with the internet somehow, however, it refuses to resolve an URL and/or IP address. It just sits there, with a white screen, not throwing an error, or logging anything within an error log.

Now, to get to your second recommendation, I thought of this too, last night, however I did not have a chance to test out this theory until this morning. When I did I was able to change the permissions for the Google folder for SYSTEM, Administrators, Users, and Trusted Installer to allow ‘Full control’. However, I still experience the same issues, even after a reboot. Now get this, I am ‘not’ able to change the permission settings for ‘CREATOR OWNER’, for whatever reason. Right now, ‘CREATOR OWNER’ does not have any permissions for this folder (including the subsequent folders underneath), and when I initially attempted to alter this, all of the ‘Allow’ permissions check-boxes cleared themselves out, after I hit apply. Doing the same and hitting ‘OK’ did not do anything either. Then, after a reboot, I attempted this again, and now when I attempt to give ‘CREATOR OWNER’ Full control and permissions, Windows bounces back with ‘Error Applying Security’ C:\Program Files (x86)\Google\CrashReports [ Access is denied ]. In addition, if I want to view this folder, Windows states “You don’t currently have permission to access this folder.”, and I have to click continue (giving administrator privileges) to access it each time.

In addition, the only user account that I currently have setup on my system is the ‘Administrator’ account. There is no other account other than this account. I did enable the ‘Guest’ account, like you suggested, and I experienced the same issues. I even uninstalled Chrome, went into the ‘Guest’ account, re-installed Chrome, and still, the same issues persist. I feel like I am going nuts over this issue. I appreciate all of the help, however, I am still at a loss, and I need to start my work and school soon. It has been a total of 5 days now that I have been wrestling with this problem, and I have no idea of what I should do next. Again, I thanks for all of your help, I do sincerely appreciate it. If you think of anything else, let me know, because I will still be pondering this until this matter is resolved. Thanks again.
m
0
l

Best solution

23 March 2013 16:25:14


Same issue here, temporarily solved by adding --reduce-gpu-sandbox in chrome shortchuts.

Problems with DisplayLink software and Google Chrome
Source thread


Share
23 March 2013 18:31:31

@razethewolf:

Brilliant, simply brilliant… this worked! Thank you so very much razethewolf, I would have never thought that this issue was brought about by a DisplayLink software driver, and the recent release of Chrome 25.0.1364.94m. Honestly, an odd conflict, however, I should not be that surprised, for I have seen my fair share of strange conflicts throughout my life. I cannot thank you enough, and now that you have exposed the root of this issue, I can use Chrome again, and attempt to resolve this situation with a more permanent fix. Like replacing my DynaDock stations (which uses the DisplayLink driver) and get a second video card to SLI… which I was planning on doing anyways, for other (unrelated) reasons. Thanks again, this is a wonderful breakthrough.

m
0
l
14 May 2013 09:38:23

wow Justinbyrne001 you went far more than I did ... I have Win7 enterprise and after a recent server wide, Chrome stopped working for many users - unfortunatly I was one of them. IT support said this is due to McAfee and Win7 Updates. No IT admin was able to get my chrome working gain even after trying some of your solutions. I am very upset for not being able to use it anymore and hesitantly and reluctantly co-existing with IE (I hate it). I implore Google to come up with a fix or update to Chrome.

Alex
m
0
l
14 May 2013 13:11:21

extenderus said:
wow Justinbyrne001 you went far more than I did ... I have Win7 enterprise and after a recent server wide, Chrome stopped working for many users - unfortunatly I was one of them. IT support said this is due to McAfee and Win7 Updates. No IT admin was able to get my chrome working gain even after trying some of your solutions. I am very upset for not being able to use it anymore and hesitantly and reluctantly co-existing with IE (I hate it). I implore Google to come up with a fix or update to Chrome.

Alex


Actually, Google (as far as I am aware) has already fixed this problem. At least on my system, Chrome works fine. After a patch, which I believe was issued approximately a month after my issue here was resolved, I was able to run Google Chrome on my system without any special (execution) tags. In addition, since then I have gotten rid of my DynaDock workstation, and I am no longer using the DisplayLink drivers that caused Chrome to behave strangley. Therefore, I have no idea if this issue may still persist for some, if they are using DisplayLink drivers.
m
0
l
25 August 2013 17:09:20

@Justin, My computer did a major update of Window 7 a little over a month ago and since then Chrome has not worked on my pc either. We have also done most everything you all have mentioned with no use. I too am at my wits end because I simply hate IE and would prefer to not have to install a dozen other browsers just to access the internet and get work done.

I was seriously thinking it was time for Windows 7 to take a flying leap straight out the window.

It is nice to know I am not the only one with this issue.

I am saving this thread so my boys can read through it and I will have them try RazeTheWolfs suggestion.

Thank you all
m
0
l
4 October 2013 20:12:38

I had the same problem with Chrome running on Windows Server 2012 inside VirtualBox.

Disabling hardware acceleration fixed it for me.
Settings->Show Advanced Settings->(disable) Use hardware acceleration when available.

J-F
m
0
l
6 December 2013 01:55:49

Change the time on the computer clock to current time and date. I just had the same problem after reformating
m
0
l
23 April 2014 16:31:54

justinbyrne001 said:
Okay, I am about to lose it, literally, because I cannot resolve this issue, and this is the ‘only’ place I know of where I can get some sound advice.

I had recently wiped my hard drive clean, to do a fresh install of Windows 7. My registry was becoming a little cluttered, and after about a year and a half of installing, updating, and upgrading software, I felt as though my system needed a fresh start. I am a software and web developer, and I like to keep my system minimal, however, I do rely on many different software packages and services to develop (i.e.: Java JDK, Apache, PHP, MySQL, UDK, Maya, Adobe, the .NET framework, and every major web-browser currently available), and it is crucial that everything works in harmony. Now, I have not even begun to install anything (other than Windows 7), and I am already experiencing the same issue repeatedly. Here is what I am experiencing.

When I install Windows 7, I ‘disable’ Windows from performing their ‘automatic updates’. In the past, have had too many experiences where one of Microsoft’s updates renders something within my system as un-functional, and I am almost 100% positive that this is occurring again, however, I cannot pin point which update is doing this, nor exactly what is causing this issues. What is happening is I cannot get Chrome to access the internet, at all. It runs, however, it will not access the internet. It is crucial for me to have this service, since this is my #1 choice for internet browsers, and (since I develop web-sites) I require it to work out cross-compatibility issues. I cannot work without this, so please, I do not need Firefox, Opera, IE, etc… fan boys suggesting that I simply switch browsers. I require as many popular browsers as possible, so that I may perform my ‘job’ as best as I can, and in all honesty, I find that chrome suites my profession better than other browsers.

Now, with that out of the way, every browser that I have installed (IE, Opera, Firefox, Safari) all work fine, except for Chrome, and I only experience this problem after I update Windows 7. I have installed Windows 7 eight times already, and each time I try something new, and I still cannot get Chrome to function. Each time I install Windows, I have been going through the same routine (after noticing this problem). I first), Install Windows, second), install motherboard drivers, third), install LAN drivers, and fourth), install Chrome. At this point, Chrome works fine, and everything is sunshine and flowers. Then, I go on to install my Video drivers (ASUS Nvidia GeForce 660 DirectCUII), USB drivers, and other peripheral drivers. Still, at this point everything works fine. Then, before I install Kasperksy Antivirus (to rule out the possibility of a conflict) I begin updating Windows 7. Now, after the first set of updates, which is something like 102 critical updates, and after I restart my computer, Chrome does not work anymore. I have tried installing chrome ‘after’ Windows 7 completes all of its updates as well, with the same result. In addition, I have also tried:

1. Running CHKDSK /R & CHKDSK /F twice in administrator mode; no errors or bad sectors found.
2. Running a DEEP antivirus/malware scan on ‘all’ of my drives, twice, and nothing was found.
3. Running Chrome with the ‘-no-sandbox’ attribute, with no effect.
4. ‘Use automatic configuration script’, and ‘Use a proxy server’ within my internet options are ‘not checked’.
5. Running Chrome in ‘incognito’ mode, with no effect.
6. I have tried repairing Window 7 three times, with no effect.
7. Clearing out my memory, 4 times, with no effect.
8. Running CCleaner to clear out my registry, with no effect.
9. Updating my BIOS, with no effect.
10. Insuring that all of my drivers are up-to-date, with no effect.
11. Using an IP address to resolve a connection, with no effect.
12. And I have restarted my machine about a thousand times, with no effect.

I understand that this is a lot, and I would honestly be in debt to whoever could assist me with this matter. Currently, I have lost 4 days of both work and school because of this problem, and I am pulling my hair out attempting to figure this issue out. Apparently there are, and have been similar cases like mine (on the internet), however, none of the suggestions that I have found have worked in my case. I thank everyone who is able to lend their assistance towards this matter in advance, and I deeply appreciate any advice or knowledge which could assist me within this matter. Thank you for your time.


m
0
l
23 April 2014 16:43:40

had the problem of clicking the chrome Icon watch it start to load then nothing I uninstalled and reinstalled and followed numerous suggestions nothing worked then I found a simple solution I went to Program files the google folder was empty so since I ws running the 64 bit version of windows 7 I went to program files x86 open the google folder and there was A google Icon that said old google you have to highlight it and click the create shortcut option to place it on your desktop it will not work if you copy and paste it once it is on the desktop you can rename it if you wish you can also drag it to the quick launch bar you don't have to but it loads like lightening.
m
0
l
15 May 2014 21:58:46

I found another workaround, but this one involves using Microsoft Security Essentials. In Settings>Excluded Files and Locations, I added the pathway for Chrome. This avoids the hassle of having to do Chrome-specific workarounds that could fail in the future when Microsoft creates new updates for Windows 7. I know this doesn't help if you're running Kaspersky, but it is feasible for those who rely upon Microsoft's own security program.
m
0
l